poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominik Stadler <dominik.stad...@gmx.at>
Subject Re: findbugs / jenkins slaves
Date Sun, 12 Jun 2016 08:17:36 GMT
Hi,

Java 9 does not yet run clean and I couldn't find any installation on
Jenkins. Also the EAPs still change quite a lot, so we would need regular
updates of the VM installation to stay up-to-date as new ones are released.

I have a script locally that sets the necessary properties when starting
the build, if anybody is interested, no actual code/build changes are
required currently.

But last time I checked there were font-related unit tests failing, I tried
to report a bug at Oracle, but did not get a response yet.

Dominik
Am 11.06.2016 21:11 schrieb "Javen O'Neal" <javenoneal@gmail.com>:

You could probably move the findbugs version (2.0.3) into a variable that's
defined inside a conditional that sets the version (2.0.3, 3.0.1) depending
on JDK version.

On Sat, Jun 11, 2016 at 10:16 AM, Andreas Beeker <kiwiwings@apache.org>
wrote:

> Hi,
>
> FYI - I'm trying to make the findbugs version depending on the java
> version, so JDK8 should use the new version.
>
> Currently Jenkins (i.e. the main poi job) is configured to the slaves
> "ubuntu&&!cloud-slave" - I probably missed it, but why
> was windows1 removed?
>
> Andi
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
> For additional commands, e-mail: dev-help@poi.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message