poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 57523] Some cells reporting as blank when they aren't
Date Wed, 11 Feb 2015 15:56:55 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=57523

Dominik Stadler <dominik.stadler@gmx.at> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |WORKSFORME

--- Comment #1 from Dominik Stadler <dominik.stadler@gmx.at> ---
Hmm, the code you pasted is very complicated and I am not sure how it shows the
problem.

When I do a very simple check, I can read those values just fine:

    @Test
    public void bug57523() {
        Workbook wb = XSSFTestDataSamples.openSampleWorkbook("57523.xlsx");
        Sheet sheet = wb.getSheetAt(1);

        Row row = sheet.getRow(1);
        Cell cellN = row.getCell(CellReference.convertColStringToIndex("N"));
        assertEquals(500.0, cellN.getNumericCellValue(), 0.00001);

        Cell cellP = row.getCell(CellReference.convertColStringToIndex("P"));
        assertEquals(10.0, cellP.getNumericCellValue(), 0.00001);
    }


Based on that I am closing this as WORKSFORME for now, please work on your code
to produce a simplified test-case which allows us to reproduce the problem more
easily and then please reopen this bug.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message