poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Banerjee, Tapas" <Tapas.Baner...@fmr.com.INVALID>
Subject getting exception on XMLEventFactory.newFatory on using poi 3.11 API.
Date Thu, 08 Jan 2015 15:00:07 GMT
We are using Apache SXSSF to export Excel. We had some issue in exporting large Excel, so we
moved to 3.11.
The API works fine in my PC, however when we deploy to our Unix server - we are getting below
exception

        at org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMa
[1/8/15 9:29:06:111 EST] 000000d9 ServletWrappe E com.ibm.ws.webcontainer.servle         
          t.ServletWrapper service Uncaught service() exception thrown by servlet ExportExcelServlet:
"java.lang.NoSuchMethodError: javax/xml/stream/XMLEventFactory.newFac              tory()Ljavax/xml/stream/XMLEventFactory;"
        at org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMa         
          rshaller.<clinit>(PackagePropertiesMarshaller.java:45)...
..
On researching the issue, I see
http://stackoverflow.com/questions/26866398/nosuchmethoderror-in-main-thread-while-reading-xlsx-using-apache-poi

Perhaps we need to upgrade java version. Our current version is:
java version "1.6.0"
Java(TM) SE Runtime Environment (build pxa6460sr8fp1ifix-2011-
0208_01(SR8 FP1++IZ81201+IZ80998+IZ83034+IZ83273+IZ94423))
IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux amd64-64 jvmxa6460sr8ifx-20100923_65174 (JIT
enabled, AOT enabled)
J9VM - 20100923_065174
JIT  - r9_20100401_15339ifx6
GC   - 20100308_AA)
JCL  - 20110208_01

Same Java works fine with POI 3.10.
What is the minimum java version we need to run 3.11?

Upgrading Java in server will take more time and tedious ask, all other application must be
tested)
Are there any jar/package we can install which can fix the issue?

Thanks,
-Tapas


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message