poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hoa sung <hoasung...@yahoo.com>
Subject Re: DO NOT REPLY [Bug 52711] Korean fonts don't render correctly
Date Mon, 01 Oct 2012 08:41:03 GMT
Could you show me your setting code for font. I have tried with code below
but It cannot render Korean characters in images


         BufferedImage img = new BufferedImage(pgsize.width , pgsize.height
,            BufferedImage.TYPE_INT_RGB);
            Graphics2D graphics = (Graphics2D)img.createGraphics();
            //clear the drawing area
            graphics.setPaint(Color.BLUE);
             //GraphicsEnvironment.getLocalGraphicsEnvironment();
            Font font = new Font("Arial Unicode MS", Font.PLAIN, 14);
            
            graphics.setFont(font);
           
  
              graphics.fill(new Rectangle2D.Float(0, 0, pgsize.width,
pgsize.height));

            slide[i].draw(graphics);
           

            //save the output
            
            FileOutputStream out = new FileOutputStream(destinationPath +
"slide-"  + (i+1) + ".png");
            javax.imageio.ImageIO.write(img, "png", out);
            
            
            
            out.close();

 Are there anyone can help me out ?           



--
View this message in context: http://apache-poi.1045710.n5.nabble.com/DO-NOT-REPLY-Bug-52711-New-Korean-fonts-don-t-render-correctly-tp5497690p5711026.html
Sent from the POI - Dev mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message