poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 53178] RunTimeException: "Unexpected tAttr" in getCellFormula()
Date Thu, 03 May 2012 09:06:11 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53178

--- Comment #2 from npaetsch@psi.de ---
The exception is thrown in org.apache.poi.ss.formula.ForumlaRenderer.

When stepping through the source code while parsing the Excel-formula 

{=WENN(('E:\Berichtswesen\Programme\pis_esm.xla'!Tmark($Q$12;"STD";$B$4;$B$4))
= "N";"No Allocation";"")}

as indicated in my second comment, the following stack is already set up

stack    Stack<E>  (id=135)    
    capacityIncrement    0    
    elementCount    2    
    elementData    Object[10]  (id=139)    
        [0]    "(Tmark(#REF!,"STD",#REF!,#REF!))="N"" (id=143)    
        [1]    ""No Allocation"" (id=1046)    
        [2]    null    
        [3]    null    
        [4]    null    
        [5]    null    
        [6]    null    
        [7]    null    
        [8]    null    
        [9]    null    
    modCount    18    

The next element ptgs[13] which is of instance AttrPtg then causes the
exception.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message