poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46493] BackGround color not working
Date Wed, 21 Jan 2009 19:15:07 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46493


Graham Smith <graham@crazysquirrel.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |graham@crazysquirrel.com
             Status|NEEDINFO                    |ASSIGNED




--- Comment #2 from Graham Smith <graham@crazysquirrel.com>  2009-01-21 11:15:05 PST
---
I don't know about version 3.2 but in 3.5 beta 4 the following code (with
suitable code around it to create a workbook and save it etc) doesn't create a
cell with a light blue background - the background is white. This functionality
worked in 3.5 beta 3 (but setting the font as bold didn't work).

Font font = wb.createFont();
font.setBoldweight( Font.BOLDWEIGHT_BOLD );

CellStyle style = wb.createCellStyle();
style.setFillBackgroundColor( IndexedColors.LIGHT_BLUE.getIndex() );
style.setFont( font );

Cell cell = row.createCell( 0 );
cell.setCellStyle( style );
cell.setCellValue( "foo" );


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message