poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45972] New: POI 3.5b3: OOXML needs too many support libraries
Date Thu, 09 Oct 2008 11:53:30 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45972

           Summary: POI 3.5b3: OOXML needs too many support libraries
           Product: POI
           Version: 3.5-dev
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSSF
        AssignedTo: dev@poi.apache.org
        ReportedBy: richard.evans@datanomic.com


You can read HSSF files using just the one POI jar.  If you want to read OOXML
files, you need several other jars - dom4j, xmlbeans etc.  Is this really
necessary given the built-in XML support in Java 5+?

Worse, the openxml4j jar includes explicit references to log4j.  It should use
the java.util.logging framework so that the log4j jars are not needed at
runtime.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message