poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Paris" <rpj...@hotmail.com>
Subject Re: Bug 17208 - WordDocument Problem: createListTables - Negative Array Size
Date Mon, 03 Mar 2003 18:47:42 GMT
>For example, the following comment is not acceptable:

Yeah, I know, but I was sort of doing filler comments so I wouldn't forget 
for later and then was going to send to you guys to check over and see if it 
all fit your understanding, etc. So those wouldn't be final comments. Sorry 
that was not clear. ;)

I do think that naming these methods and variables in a Java way would make 
it MUCH easier to follow. Then we could also standardize the comments for 
everything and do something like this:

* MS Spec Correlation: pclfhdd array
* Description:
* Blah, Blah...
createHeaderFooterArray( tableByteArray );

To me that's a lot cleaner, it shows the correlation to the spec (so it's 
easy to find) but it keeps the horrible MS coding style from ruining our 
nice, clean, easy to follow Java coding style.

What does everyone think?

Add photos to your e-mail with MSN 8. Get 2 months FREE*.  

View raw message