poi-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fannin...@apache.org
Subject svn commit: r1856094 - in /poi/site/src/documentation/content/xdocs: changes.xml components/index.xml
Date Fri, 22 Mar 2019 23:24:47 GMT
Author: fanningpj
Date: Fri Mar 22 23:24:47 2019
New Revision: 1856094

URL: http://svn.apache.org/viewvc?rev=1856094&view=rev
Log:
xmlbeans 3.1.0

Modified:
    poi/site/src/documentation/content/xdocs/changes.xml
    poi/site/src/documentation/content/xdocs/components/index.xml

Modified: poi/site/src/documentation/content/xdocs/changes.xml
URL: http://svn.apache.org/viewvc/poi/site/src/documentation/content/xdocs/changes.xml?rev=1856094&r1=1856093&r2=1856094&view=diff
==============================================================================
--- poi/site/src/documentation/content/xdocs/changes.xml (original)
+++ poi/site/src/documentation/content/xdocs/changes.xml Fri Mar 22 23:24:47 2019
@@ -92,11 +92,12 @@
         <summary-item>New EMF renderer and support of SVG images in XSLF</summary-item>
         <summary-item>Security, stability and memory/resource handling improvements</summary-item>
         <summary-item>Various bug fixes across function and conditional format rule
evaluation</summary-item>
-        <summary-item>Upgrade to XMLBeans 3.0.3</summary-item>
+        <summary-item>Upgrade to XMLBeans 3.1.0</summary-item>
         <summary-item>Upgrade to Bouncycastle 1.61</summary-item>
         <summary-item>Upgrade to Curvesapi 1.06</summary-item>
         <summary-item>Upgrade to Commons-Codec 1.12</summary-item>
         <summary-item>Upgrade to Commons-Collections4 4.3</summary-item>
+        <summary-item>Upgrade to XMLSec 2.1.2</summary-item>
       </summary>
       <actions>
         <action dev="PD" type="fix" fixes-bug="62151" context="POIFS">Work around illegal
reflective access in Java 9+ when freeing buffers</action>

Modified: poi/site/src/documentation/content/xdocs/components/index.xml
URL: http://svn.apache.org/viewvc/poi/site/src/documentation/content/xdocs/components/index.xml?rev=1856094&r1=1856093&r2=1856094&view=diff
==============================================================================
--- poi/site/src/documentation/content/xdocs/components/index.xml (original)
+++ poi/site/src/documentation/content/xdocs/components/index.xml Fri Mar 22 23:24:47 2019
@@ -318,7 +318,7 @@
         </tr>
         <tr>
           <td>poi-ooxml-schemas</td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.0.1|jar">xmlbeans</a></td>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.1.0|jar">xmlbeans</a></td>
           <td>poi-ooxml-schemas-version-yyyymmdd.jar</td>
         </tr>
         <tr>
@@ -331,12 +331,12 @@
         </tr>
         <tr>
           <td>ooxml-schemas</td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.0.3|jar">xmlbeans</a></td>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.1.0|jar">xmlbeans</a></td>
           <td><a href="https://search.maven.org/#artifactdetails|org.apache.poi|ooxml-schemas|1.4|jar">ooxml-schemas-1.4.jar</a></td>
         </tr>
         <tr>
           <td>ooxml-security</td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.0.3|jar">xmlbeans</a><br/>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.1.0|jar">xmlbeans</a><br/>
           For signing: 
           <a href="https://search.maven.org/#artifactdetails|org.bouncycastle|bcpkix-jdk15on|1.61|jar">bcpkix-jdk15on</a>,
           <a href="https://search.maven.org/#artifactdetails|org.bouncycastle|bcprov-jdk15on|1.61|jar">bcprov-jdk15on</a>,
@@ -376,7 +376,7 @@
       <p>
         The ooxml schemas jars are compiled with <a href="https://xmlbeans.apache.org/">Apache
XMLBeans</a> 2.3, and so
         can be used at runtime with any version of XMLBeans from 3.0.0 or newer.
-        Wherever possible though, we recommend that you use XMLBeans 3.0.3
+        Wherever possible though, we recommend that you use XMLBeans 3.1.0
         with Apache POI, and that is the version now shipped in the binary
         release packages.
       </p>



---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@poi.apache.org
For additional commands, e-mail: commits-help@poi.apache.org


Mime
View raw message