poi-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From n...@apache.org
Subject svn commit: r1841353 - /poi/site/src/documentation/content/xdocs/components/index.xml
Date Wed, 19 Sep 2018 16:02:48 GMT
Author: nick
Date: Wed Sep 19 16:02:48 2018
New Revision: 1841353

URL: http://svn.apache.org/viewvc?rev=1841353&view=rev
Log:
Mention Commons Compress is needed for OOXML, bump xmlbeans and ooxml-schemas versions referenced

Modified:
    poi/site/src/documentation/content/xdocs/components/index.xml

Modified: poi/site/src/documentation/content/xdocs/components/index.xml
URL: http://svn.apache.org/viewvc/poi/site/src/documentation/content/xdocs/components/index.xml?rev=1841353&r1=1841352&r2=1841353&view=diff
==============================================================================
--- poi/site/src/documentation/content/xdocs/components/index.xml (original)
+++ poi/site/src/documentation/content/xdocs/components/index.xml Wed Sep 19 16:02:48 2018
@@ -307,13 +307,14 @@
         <tr>
           <td>poi-ooxml</td>
           <td><a href="https://search.maven.org/#search|gav|1|g:org.apache.poi AND
a:poi">poi</a>,
-              <a href="https://search.maven.org/#search|gav|1|g:org.apache.poi AND a:poi-ooxml-schemas">poi-ooxml-schemas</a>
+              <a href="https://search.maven.org/#search|gav|1|g:org.apache.poi AND a:poi-ooxml-schemas">poi-ooxml-schemas</a>,
+              <a href="https://search.maven.org/#artifactdetails|org.apache.commons|commons-compress|1.18|jar">commons-compress</a>
(since POI 4.0.0),
           </td>
           <td>poi-ooxml-version-yyyymmdd.jar</td>
         </tr>
         <tr>
           <td>poi-ooxml-schemas</td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|2.6.0|jar">xmlbeans</a></td>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.0.1|jar">xmlbeans</a></td>
           <td>poi-ooxml-schemas-version-yyyymmdd.jar</td>
         </tr>
         <tr>
@@ -326,12 +327,12 @@
         </tr>
         <tr>
           <td>ooxml-schemas</td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|2.6.0|jar">xmlbeans</a></td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.poi|ooxml-schemas|1.3|jar">ooxml-schemas-1.3.jar</a></td>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.0.1|jar">xmlbeans</a></td>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.poi|ooxml-schemas|1.4|jar">ooxml-schemas-1.4.jar</a></td>
         </tr>
         <tr>
           <td>ooxml-security</td>
-          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|2.6.0|jar">xmlbeans</a><br/>
+          <td><a href="https://search.maven.org/#artifactdetails|org.apache.xmlbeans|xmlbeans|3.0.1|jar">xmlbeans</a><br/>
           For signing: 
           <a href="https://search.maven.org/#artifactdetails|org.bouncycastle|bcpkix-jdk15on|1.59|jar">bcpkix-jdk15on</a>,
           <a href="https://search.maven.org/#artifactdetails|org.bouncycastle|bcprov-jdk15on|1.59|jar">bcprov-jdk15on</a>,
@@ -349,8 +350,9 @@
       </note>
       <p>
         poi-ooxml requires poi-ooxml-schemas. This is a substantially smaller 
-        version of the ooxml-schemas jar (ooxml-schemas-1.3.jar for POI 3.14 or 
-        later, ooxml-schemas-1.1.jar for POI 3.7 up to POI 3.13, ooxml-schemas-1.0.jar 
+        version of the ooxml-schemas jar (ooxml-schemas-1.4.jar for POI 4.0.0 
+        or later, ooxml-schemas-1.3.jar for POI 3.14 or to POI 3.17, 
+        ooxml-schemas-1.1.jar for POI 3.7 up to POI 3.13, ooxml-schemas-1.0.jar 
         for POI 3.5 and 3.6).
         The larger ooxml-schemas jar is <a href="../help/index.html#faq-N10025">normally</a>

         only required for development. Similarly, the ooxml-security jar, which contains
@@ -370,11 +372,9 @@
       <p>
         The ooxml schemas jars are compiled with <a href="https://xmlbeans.apache.org/">Apache
XMLBeans</a> 2.3, and so
         can be used at runtime with any version of XMLBeans from 2.3 or newer.
-        Wherever possible though, we recommend that you use XMLBeans 2.6.0
+        Wherever possible though, we recommend that you use XMLBeans 3.0.1
         with Apache POI, and that is the version now shipped in the binary
         release packages.
-        If you have issues with redefined classes with XMLBeans 2.6, ask
-        on the <a href="site:mailinglists">developer mailing list</a> for solutions.
       </p>
     </section>
     <section><title>Examples</title>



---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@poi.apache.org
For additional commands, e-mail: commits-help@poi.apache.org


Mime
View raw message