plc4x-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christofer Dutz (JIRA)" <j...@apache.org>
Subject [jira] [Created] (PLC4X-107) Make the other drivers support the latest API changes
Date Sun, 17 Mar 2019 10:14:00 GMT
Christofer Dutz created PLC4X-107:
-------------------------------------

             Summary: Make the other drivers support the latest API changes
                 Key: PLC4X-107
                 URL: https://issues.apache.org/jira/browse/PLC4X-107
             Project: Apache PLC4X
          Issue Type: Task
          Components: Driver-ADS, Driver-Ethernet/IP, Driver-Modbus
            Reporter: Christofer Dutz
            Assignee: Tim Mitsch


There have been API changes, that now must result in PlcRuntimeExceptions for all drivers
except the S7 driver. This is because only this Driver implements the "parse" method and the
default implementation simply throws this exception. 

Even if technically now the Scraper no longer depends on the S7 driver, still it does, as
this is the only driver that overrides this default method. 

If API changes are made, we should ensure these are propagated to affected drivers or we will
be having big problems of keeping stuff synced in the future.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message