plc4x-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: Scraper tests failing on Windows machines ...
Date Fri, 18 Jan 2019 08:50:58 GMT
Hi all,

well it seems that on some systems the mocked "getConnection" method is called, and on some
they aren't.
If a method is stubbed, but the test doesn't call it, Mockito tends to fail the test. However
when commenting out the method stub, the test still seems to pass ... so I'm a little confused.

Chris

Am 18.01.19, 07:59 schrieb "Julian Feinauer" <j.feinauer@pragmaticminds.de>:

    To my excuse (I guss it was me...) it happened on Mallorca and I think there was some
Beer involved... : )
    
    Am 17.01.19, 22:31 schrieb "Christofer Dutz" <christofer.dutz@c-ware.de>:
    
        Aaaaahhh ... that's what it means!!!
        
        Gotta start using this if I ever have to go to a Bank again ... in every meeting I'll
just be polite and say "STFU" all the time ;-)
        
        Chris
        
        Am 17.01.19, 18:42 schrieb "Justin Mclean" <justinmclean@me.com>:
        
            Hi,
            
            > I can see a lot of “Unable to instantiate connection to mock:scraper”
messages. And a lot of PlcConnectionException with the message “stfu” (we should use a
little milder wording here, I think)
            
            What’s wrong with "Say, Thanks for Understanding”? :-)
            
            Thanks,
            Justin
        
        
    
    

Mime
View raw message