pivot-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk Möbius <dmoeb...@scoop-gmbh.de>
Subject Re: Component names inside the containers
Date Tue, 08 Jun 2010 22:03:05 GMT
Greg Brown wrote:
> We don't actually need an annotation for this. Simply adding the getter and setter is
sufficient to support the "name" attribute.

Oh, I thought the wtkx:id should be used as the name. So that you don't 
have to set an id AND a name:

<PushButton wktx:id="myButton"/>

looks better than:

<PushButton wktx:id="myButton" name="myButton"/>

I thought it would have been considered as a general good thing to have 
the wtkx:id injected into any object instance (of any type, in case it's 


View raw message