pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohini Palaniswamy (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (PIG-5317) Upgrade old dependencies: commons-lang, hsqldb, commons-logging
Date Wed, 03 Jan 2018 16:29:00 GMT

    [ https://issues.apache.org/jira/browse/PIG-5317?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16309874#comment-16309874
] 

Rohini Palaniswamy edited comment on PIG-5317 at 1/3/18 4:28 PM:
-----------------------------------------------------------------

I am also seeing the following e2e tests

{code}
 BloomJoin_Map.BloomJoin_Map_7
 BloomJoin_Reduce.BloomJoin_Reduce_7
 CastScalar.CastScalar_11
 MultiQuery_MapReduceSplitee.MultiQuery_MapReduceSplitee_7
 MultiQuery_Self.MultiQuery_Self_4
 MultiQuery_Self.MultiQuery_Self_9
 MultiQuery_Union.MultiQuery_Union_3
 MultiQuery_Union.MultiQuery_Union_4
 MultiQuery_Union.MultiQuery_Union_5
 MultiQuery_Union.MultiQuery_Union_8
 MultiQuery_Union.MultiQuery_Union_12
 Scalar.Scalar_5
{code}

fail with

{code}
java.lang.NoClassDefFoundError: org/apache/commons/lang3/ArrayUtils
	at org.apache.pig.backend.hadoop.executionengine.tez.util.TezCompilerUtil.replaceOutput(TezCompilerUtil.java:192)
{code}


was (Author: rohini):
I am also seeing this error

{code}
java.lang.NoClassDefFoundError: org/apache/commons/lang3/ArrayUtils
	at org.apache.pig.backend.hadoop.executionengine.tez.util.TezCompilerUtil.replaceOutput(TezCompilerUtil.java:192)
{code}

> Upgrade old dependencies: commons-lang, hsqldb, commons-logging
> ---------------------------------------------------------------
>
>                 Key: PIG-5317
>                 URL: https://issues.apache.org/jira/browse/PIG-5317
>             Project: Pig
>          Issue Type: Improvement
>            Reporter: Nandor Kollar
>            Assignee: Nandor Kollar
>            Priority: Minor
>             Fix For: 0.18.0
>
>         Attachments: PIG-5317_1.patch, PIG-5317_2.patch, PIG-5317_amend.patch
>
>
> Pig depends on old version of commons-lang, hsqldb and commons-logging. It would be nice
to upgrade the version of these dependencies, for commons-lang Pig should depend on commons-lang3
instead (which is already present in the ivy.xml)



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message