pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nandor Kollar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PIG-5191) Pig HBase 2.0.0 support
Date Thu, 16 Mar 2017 12:39:41 GMT

    [ https://issues.apache.org/jira/browse/PIG-5191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15927922#comment-15927922
] 

Nandor Kollar commented on PIG-5191:
------------------------------------

Either we can solve this via shims (like we had shims for different Hadoop version), or we
can use reflection. [~rohini] what do you think, which one would you prefer? Do you have any
other idea for supporting two different HBase APIs? I'd prefer shims, because I think the
code gets cleaner, not overwhelmed with reflection code and with reflection we'll get exception
at runtime, if incorrect HBase version is used.

> Pig HBase 2.0.0 support
> -----------------------
>
>                 Key: PIG-5191
>                 URL: https://issues.apache.org/jira/browse/PIG-5191
>             Project: Pig
>          Issue Type: Improvement
>            Reporter: Nandor Kollar
>             Fix For: 0.17.0
>
>
> Pig doesn't support HBase 2.0.0. Since the new HBase API introduces several API changes,
we should find a way to support both 1.x and 2.x HBase API.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message