pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohini Palaniswamy (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PIG-4728) Compilation against hbase 1.x fails with hbase-hadoop1-compat not found
Date Wed, 11 Jan 2017 15:13:58 GMT

     [ https://issues.apache.org/jira/browse/PIG-4728?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rohini Palaniswamy updated PIG-4728:
------------------------------------
    Hadoop Flags: Incompatible change
    Release Note: HBase 1.x and above will be supported with Pig 0.17. Compiling with 0.98
or below versions will require reversing this patch.

Marking this jira backward incompatible, as after this only HBase 1.x and above will be supported.
Compiling with 0.98 or below versions will not work.

[~szita],
I think hbase-procedure should be part of test->default. It is a server side jar and not
required by the client. I don't see that in https://github.com/apache/hbase/blob/master/hbase-server/src/main/java/org/apache/hadoop/hbase/mapreduce/TableMapReduceUtil.java#L767-L798



> Compilation against hbase 1.x fails with hbase-hadoop1-compat not found
> -----------------------------------------------------------------------
>
>                 Key: PIG-4728
>                 URL: https://issues.apache.org/jira/browse/PIG-4728
>             Project: Pig
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Assignee: Adam Szita
>             Fix For: 0.17.0
>
>         Attachments: PIG-4728-1.patch, PIG-4728-2.patch
>
>
> With the following change:
> {code}
> diff --git a/ivy/libraries.properties b/ivy/libraries.properties
> index c40befd..41ce9fb 100644
> --- a/ivy/libraries.properties
> +++ b/ivy/libraries.properties
> @@ -46,7 +46,7 @@ hadoop-common.version=2.6.0
>  hadoop-hdfs.version=2.6.0
>  hadoop-mapreduce.version=2.6.0
>  hbase94.version=0.94.1
> -hbase95.version=0.98.12-${hbase.hadoop.version}
> +hbase95.version=1.1.2
>  hsqldb.version=1.8.0.10
>  hive.version=1.2.1
>  httpcomponents.version=4.1
> {code}
> I ran 'ant compile'
> However, compilation failed with:
> {code}
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 		::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 		:: org.apache.hbase#hbase-hadoop1-compat;1.1.2: not found
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> {code}
> In hbase 1.x releases, hbase-hadoop1-compat module doesn't exist.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message