pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohit Sabharwal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PIG-4586) Cleanup: Rename POConverter to RDDConverter
Date Thu, 04 Jun 2015 17:34:39 GMT

    [ https://issues.apache.org/jira/browse/PIG-4586?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14573206#comment-14573206
] 

Mohit Sabharwal commented on PIG-4586:
--------------------------------------

[~kellyzly], the "PO" prefix is used by operators. But "POConverter" is not an operator. So
I think it will confuse someone looking at the code for the first time.

RDDConverter is an alternative name ("Class that converts physical operators to RDDs").

Let me know if you have any other suggestions for the name.

> Cleanup: Rename POConverter to RDDConverter
> -------------------------------------------
>
>                 Key: PIG-4586
>                 URL: https://issues.apache.org/jira/browse/PIG-4586
>             Project: Pig
>          Issue Type: Sub-task
>          Components: spark
>    Affects Versions: spark-branch
>            Reporter: Mohit Sabharwal
>            Assignee: Mohit Sabharwal
>             Fix For: spark-branch
>
>         Attachments: PIG-4586.1.patch, PIG-4586.patch
>
>
> PO prefix should apply to operators



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message