pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Dai (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PIG-4481) e2e tests ComputeSpec_1, ComputeSpec_2 and StreamingPerformance_3 produce different result on Windows
Date Tue, 24 Mar 2015 03:44:52 GMT

     [ https://issues.apache.org/jira/browse/PIG-4481?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Dai updated PIG-4481:
----------------------------
    Attachment: PIG-4481-1.patch

> e2e tests ComputeSpec_1, ComputeSpec_2 and StreamingPerformance_3 produce different result
on Windows
> -----------------------------------------------------------------------------------------------------
>
>                 Key: PIG-4481
>                 URL: https://issues.apache.org/jira/browse/PIG-4481
>             Project: Pig
>          Issue Type: Bug
>          Components: e2e harness
>            Reporter: Daniel Dai
>            Assignee: Daniel Dai
>              Labels: windows
>             Fix For: 0.15.0
>
>         Attachments: PIG-4481-1.patch
>
>
> ComputeSpec_1, ComputeSpec_2 and StreamingPerformance_3 produce the wrong result on Windows.
Since Pig compare the test result with old version of Pig, which also produce wrong result,
the test still pass.
> The cause of the issue is the parameter passing under Windows. Some parameter of executable
cannot pass correctly on Windows. StreamingPerformance_3 requires a simple quoting change.
However, I didn't find a proper way to fix ComputeSpec_1 and ComputeSpec_2. Changing the test
slightly to get around (not changing the intention of the test).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message