pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PIG-4083) TestAccumuloPigCluster always failed with timeout error
Date Fri, 01 Aug 2014 15:20:38 GMT

    [ https://issues.apache.org/jira/browse/PIG-4083?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14082331#comment-14082331
] 

Josh Elser commented on PIG-4083:
---------------------------------

The timeout is set globally for the Pig Junit Ant task for 2 hours. This is defined in the
build.xml and you can change it. This failure case should occur in a minute or so -- very
quickly.

Looking at the logs you provided showed that when the Accumulo processes attempted to start,
they had the incorrect Thrift jars on the classpath which caused:

{noformat}
Caused by: java.lang.NoSuchMethodError: org.apache.thrift.EncodingUtils.setBit(BIZ)B
{noformat}

The classpath was also printed out in the same log files that you attached in that tarball.
It appears that there is only libthrift-0.9.0 included, which is correct. The problem now
is trying to figure out what artifact included on the classpath is also bundling Thrift classes.
I ran a diff against the classpaths that your accumulo test was running with and mine, and
found the offender: {{/root/ff/git/pig/lib/hive-exec-0.8.0.jar}}. That old version of Hive
is shading in Thrift classes (from 0.6 IIRC) which is where the errors are coming from.

Your classpath actually has a bunch more entries than mine, notably a dozen or so all from
{{/root/ff/git/pig/lib/}}. I'll try to poke around -- I forget where/how that lib directory
is used. I'll also see what I can do about the underlying AccumuloMiniCluster issue. We may
have a better fix in a newer version of Accumulo we could upgrade to, otherwise, we might
be able to determine when the processes immediately died and avoid the infinite loop of the
test code trying to connect to an Accumulo that isn't alive.




> TestAccumuloPigCluster always failed with timeout error
> -------------------------------------------------------
>
>                 Key: PIG-4083
>                 URL: https://issues.apache.org/jira/browse/PIG-4083
>             Project: Pig
>          Issue Type: Bug
>    Affects Versions: 0.13.0
>            Reporter: fang fang chen
>            Assignee: Josh Elser
>            Priority: Critical
>         Attachments: PIG-4083-debug.patch, pig_junit_tmp827919480.tar.gz
>
>
> TestAccumuloPigCluster always failed with timeout error.
> Tried with sun jdk 6 and sun jdk 7.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message