pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cheolsoo Park (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PIG-3905) 0.12.1 release can't be build for Hadoop2
Date Mon, 21 Apr 2014 19:28:17 GMT

    [ https://issues.apache.org/jira/browse/PIG-3905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13975932#comment-13975932
] 

Cheolsoo Park commented on PIG-3905:
------------------------------------

+1. It works for me. Thanks for the patch Daniel!

> 0.12.1 release can't be build for Hadoop2
> -----------------------------------------
>
>                 Key: PIG-3905
>                 URL: https://issues.apache.org/jira/browse/PIG-3905
>             Project: Pig
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.12.1
>            Reporter: Konstantin Boudnik
>            Priority: Blocker
>         Attachments: PIG-3905-1.patch
>
>
> While building Pig against {{hadoopversion=23}},  attempts to resolve {{hadoop-core}}
dependency no matter what. The root cause of the bug is the following lines in ivy.xml
> {noformat}
>     <dependency org="com.sun.jersey" name="jersey-core" rev="${jersey-core.version}"
>       conf="hadoop20->default"/>
>     <dependency org="org.apache.hadoop" name="hadoop-core" rev="${hadoop-core.version}"
>       conf="hadoop20->default"/>
>     <dependency org="org.apache.hadoop" name="hadoop-test" rev="${hadoop-test.version}"
>       conf="hadoop20->default"/>
> {noformat}
> hadoop20 configuration is getting evaluated _always_. Unless a build machine has dirty
local .m2 repository, the build will fail.
> The bug blocks BIGTOP-1110



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message