pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajitha Ranasinghe <rajithay...@gmail.com>
Subject Problem with building latest version
Date Sun, 23 Feb 2014 15:10:03 GMT
Hi,

I did the followings,

1. Got the latest version from SVN.
2. mvn clean eclipse-files
3. mvn compile gen
4. Got an error Missing required library:
'build/ivy/lib/Pig/javacc-4.2.jar' pig
5. So I applied patch
https://issues.apache.org/jira/secure/attachment/12600505/PIG-3399-1.patch
6.Then I got the following errors,

The declared package "org.apache.pig.test.pigmix.datagen" does not match
the expected package
"perf.pigmix.src.java.org.apache.pig.test.pigmix.datagen"
The declared package "org.apache.pig.test.pigmix.udf" does not match the
expected package "perf.pigmix.src.java.org.apache.pig.test.pigmix.udf"
The import org.apache.pig.test.pigmix cannot be resolved
The import sdsu cannot be resolved DataGenerator.java
/trunk/test/perf/pigmix/src/java/org/apache/pig/test/pigmix/datagen
Zipf cannot be resolved to a type

Any solution?

Cheers.
---
Rajitha

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message