pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julien Le Dem <jul...@twitter.com>
Subject Re: inconsistency between ivy/library.properties and .eclipse.templates/.classpath
Date Wed, 06 Feb 2013 19:08:26 GMT
try "ant eclipse-files"
I don't think it uses this template anymore.


On Wed, Feb 6, 2013 at 10:10 AM, Kyungho Jeon <kyungho.jeon@gmail.com>wrote:

> Hello,
>
> I recently started hacking Apache Pig. I tried to import the source
> code into eclipse, and got some "missing required library" errors.
>
> I found for some libraries .eclipse.templates/.classpath specifies
> older versions. Shouldn't it be updated according to
> ivy/library.properties?
>
> In addition, .classpath specifies both javacc-4.2.jar and javacc.jar,
> but build.xml moves javacc-4.2.jar to javacc.jar. Shouldn't the line
> containing javacc-4.2.jar be removed from .classpath?
>
> I am attaching my diff (patch) that works for me.
>
> Thanks,
> Kyungho.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message