pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Coveney (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PIG-2379) Bug in Schema.getPigSchema(ResourceSchema rSchema) improperly adds two level access
Date Thu, 17 Nov 2011 04:18:51 GMT

     [ https://issues.apache.org/jira/browse/PIG-2379?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Coveney updated PIG-2379:
----------------------------------

    Attachment: PIG2379.patch
    
> Bug in Schema.getPigSchema(ResourceSchema rSchema) improperly adds two level access
> -----------------------------------------------------------------------------------
>
>                 Key: PIG-2379
>                 URL: https://issues.apache.org/jira/browse/PIG-2379
>             Project: Pig
>          Issue Type: Bug
>    Affects Versions: 0.10, 0.9.2, 0.11
>            Reporter: Jonathan Coveney
>            Assignee: Jonathan Coveney
>             Fix For: 0.11
>
>         Attachments: PIG2379.patch
>
>
> If you do this:
> Schema s1=Utils.getSchemaFromString("b:bag{t:tuple(name:chararray,age:int)}");
> Schema s2=Schema.getPigSchema(new ResourceSchema(s1));
> System.out.println(s1.equals(s2)); //false!!
> That's super weird! The reason is that getPigSchema was setting two level access to true
for bags. I added a test, and deleted the piece that set it. I worked with trunk, but a cursory
glance makes it appear that it should be able to work with other versions as well, as I don't
think that code has changed for a while. I ran test-commit without issue, but haven't ran
the full test suite.
> I appreciate any feedback on this!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message