pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitriy V. Ryaboy (JIRA)" <j...@apache.org>
Subject [jira] Commented: (PIG-1680) Pig 0.8 HBaseStorage may not against HBase 0.89
Date Fri, 04 Mar 2011 07:37:36 GMT

    [ https://issues.apache.org/jira/browse/PIG-1680?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13002489#comment-13002489
] 

Dmitriy V. Ryaboy commented on PIG-1680:
----------------------------------------

Committed to trunk.
Leaving ticket open until a 0.8 version is committed.

> Pig 0.8 HBaseStorage may not against HBase 0.89
> -----------------------------------------------
>
>                 Key: PIG-1680
>                 URL: https://issues.apache.org/jira/browse/PIG-1680
>             Project: Pig
>          Issue Type: Task
>          Components: impl
>    Affects Versions: 0.8.0
>            Reporter: George P. Stathis
>            Assignee: Dmitriy V. Ryaboy
>             Fix For: 0.9.0
>
>         Attachments: PIG-1680.3.patch, PIG_1680.patch, PIG_1680.patch, PIG_1680.patch,
apply-PIG-1680-patch-0.8.0.sh, apply-PIG-1680-patch.sh, hbase-0.90.0-tests.jar, pig-0.8.0-hbase-0.89.SNAPSHOT.patch,
pig-1680-minicluster-fixes.txt, pig-1680-with-ivy.xml, pig-hbase-0.89.SNAPSHOT.patch, pig_1680.final.patch
>
>
> HBaseStorage is currently coded against the hbase 0.20.6 API. The hbase 0.89 API deprecates
some methods and outright removes some others which causes HBaseStorage to no longer compile.
> It is unclear whether one can run an HBase 0.20.6 client against a running 0.89 hbase
instance. In my experience, it does not work. Therefore, HBaseStorage has to be compiled against
0.89. 
> Attached is a proposed patch to make 0.8.0 trunk compatible with hbase 0.89 as well as
a script to help automate the upgrade.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message