pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olga Natkovich (JIRA)" <j...@apache.org>
Subject [jira] Commented: (PIG-1640) bin/pig does not run in local mode due to classes missing from classpath
Date Tue, 07 Dec 2010 19:28:12 GMT

    [ https://issues.apache.org/jira/browse/PIG-1640?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12968904#action_12968904
] 

Olga Natkovich commented on PIG-1640:
-------------------------------------

I looked into this issue and was able to reproduce the behavior. The problem is that we are
bundling and using wrong pig.jar. I will be fixing that as part of the release process

> bin/pig does not run in local mode due to classes missing from classpath
> ------------------------------------------------------------------------
>
>                 Key: PIG-1640
>                 URL: https://issues.apache.org/jira/browse/PIG-1640
>             Project: Pig
>          Issue Type: Bug
>    Affects Versions: 0.8.0
>            Reporter: Olga Natkovich
>            Assignee: Olga Natkovich
>             Fix For: 0.8.0
>
>
> This issue was reported by one of Yahoo users. I have not verified the problem. Here
is the report
> "when do bin/pig -x local, the shell doesn't come up.  It complained about jline not
being found.  Here is a patch to bin/pig:
> +for f in $PIG_HOME/build/ivy/lib/Pig/*.jar; do
> +    CLASSPATH=${CLASSPATH}:$f;
> +done
> +"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message