pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "George P. Stathis (JIRA)" <j...@apache.org>
Subject [jira] Created: (PIG-1680) Pig 0.8 HBaseStorage may not against HBase 0.89
Date Thu, 14 Oct 2010 16:08:39 GMT
Pig 0.8 HBaseStorage may not against HBase 0.89
-----------------------------------------------

                 Key: PIG-1680
                 URL: https://issues.apache.org/jira/browse/PIG-1680
             Project: Pig
          Issue Type: Task
          Components: impl
    Affects Versions: 0.8.0
            Reporter: George P. Stathis
             Fix For: 0.8.0


HBaseStorage is currently coded against the hbase 0.20.6 API. The hbase 0.89 API deprecates
some methods and outright removes some others which causes HBaseStorage to no longer compile.

It is unclear whether one can run an HBase 0.20.6 client against a running 0.89 hbase instance.
In my experience, it does not work. Therefore, HBaseStorage has to be compiled against 0.89.


Attached is a proposed patch to make 0.8.0 trunk compatible with hbase 0.89 as well as a script
to help automate the upgrade.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message