pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pradeep Kamath (JIRA)" <j...@apache.org>
Subject [jira] Commented: (PIG-1287) Use hadoop-0.20.2 with pig 0.7.0 release
Date Wed, 17 Mar 2010 23:30:27 GMT

    [ https://issues.apache.org/jira/browse/PIG-1287?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12846668#action_12846668
] 

Pradeep Kamath commented on PIG-1287:
-------------------------------------

bq The unit test failures are because hadoop QA process is not using the hadoop.jar attached
in this patch - I ran tests locally on mymachine with the new jar and they all passed.

The failing tests were only in TestCounters - these were broken with hadoop 0.20.1 due to
pig's use of the new hadoop API  (see PIG-1203 which had disabled TestCounters from our  "test"
ant target). In the patch in this issue, I re-enabled TestCounters and the tests in it were
the only ones which failed in the hadoop QA run. Hadoop-0.20.2 addresses the issue in hadoop
due to which TestCounters was failing - hence they pass if the hadoop20.jar attached in this
patch is used.

All other unit tests succeeded and all tests I ran on a hadoop-0.20.1 cluster also succeeded.
I also checked with folks from the hadoop development team that the changes in hadoop 0.20.2
are not supposed to be backward incompatible with hadoop 0.20.1.



> Use hadoop-0.20.2 with pig 0.7.0 release
> ----------------------------------------
>
>                 Key: PIG-1287
>                 URL: https://issues.apache.org/jira/browse/PIG-1287
>             Project: Pig
>          Issue Type: Task
>    Affects Versions: 0.7.0
>            Reporter: Pradeep Kamath
>            Assignee: Pradeep Kamath
>             Fix For: 0.7.0
>
>         Attachments: hadoop20.jar, PIG-1287-2.patch, PIG-1287.patch
>
>
> Use hadoop-0.20.2 with pig 0.7.0 release

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message