pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Dunning <tdunn...@veoh.com>
Subject Re: [jira] Commented: (PIG-23) Make Pig work with Java 1.5
Date Wed, 07 Nov 2007 21:28:43 GMT


I develop on a mac and don't have access to 1.6 unless I am connected to
machines in my office.  Requiring 1.6 would be a real pain in the ass.

In addition, as of a month and a half ago, 1.6 was demonstrably less stable
for us than 1.5 in our production applications.  I could run 1.6 just for
hadoop, but I would really rather wait until 1.6 is really stable.  When I
say less stable, I mean that over a period of a week or so, servers with
heavy load would crash due to mysterious causes about 5 times with 1.6 and
virtually never with 1.5.  The differences were statistically significant
and persistent.


On 11/7/07 11:34 AM, "Owen O'Malley (JIRA)" <jira@apache.org> wrote:

> 
>     [ 
> https://issues.apache.org/jira/browse/PIG-23?page=com.atlassian.jira.plugin.sy
> stem.issuetabpanels:comment-tabpanel#action_12540855 ]
> 
> Owen O'Malley commented on PIG-23:
> ----------------------------------
> 
> Arguably, we should move Hadoop to require 1.6. In practice, the performance
> of the servers is much much better under 1.6...
> 
>> Make Pig work with Java 1.5
>> ---------------------------
>> 
>>                 Key: PIG-23
>>                 URL: https://issues.apache.org/jira/browse/PIG-23
>>             Project: Pig
>>          Issue Type: Improvement
>>          Components: impl
>>    Affects Versions: 0.0.0
>>         Environment: All
>>            Reporter: Milind Bhandarkar
>>             Fix For: 0.1.0
>> 
>> 
>> With a few changes, I am able to make Pig build with Java 1.5. I need it to
>> work with JDK5, because my Mac does not have JDK 6.


Mime
View raw message