pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Milind Bhandarkar (JIRA)" <j...@apache.org>
Subject [jira] Commented: (PIG-23) Make Pig work with Java 1.5
Date Wed, 07 Nov 2007 18:24:51 GMT

    [ https://issues.apache.org/jira/browse/PIG-23?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12540829
] 

Milind Bhandarkar commented on PIG-23:
--------------------------------------

Olga, I see three issues:

1. Java 1.6 is the *latest* version. Sysadmins and deployments *usually* stay a version behind.
2. Hadoop, which Pig depends on, requires 1.5 only.
3. Mac OSX (even Leopard) does not have 1.6 yet (AFAIK).

Ben, e.toString() includes the stack-trace for e already, right ?

> Make Pig work with Java 1.5
> ---------------------------
>
>                 Key: PIG-23
>                 URL: https://issues.apache.org/jira/browse/PIG-23
>             Project: Pig
>          Issue Type: Improvement
>          Components: impl
>    Affects Versions: 0.0.0
>         Environment: All
>            Reporter: Milind Bhandarkar
>             Fix For: 0.1.0
>
>         Attachments: pig.patch
>
>
> With a few changes, I am able to make Pig build with Java 1.5. I need it to work with
JDK5, because my Mac does not have JDK 6.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message