phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "larsh@apache.org" <la...@apache.org>
Subject Re: Latest Phoenix built from 4.x prevent HBase from starting
Date Fri, 15 May 2020 23:10:30 GMT
I can fix that by copying phoenix-hbase-compat-1.5.0-4.16.0-SNAPSHOT.jar from phoenix/lib to
hbase/lib.
That is not intended I assume. There used to be just the Phoenix server jar needed.


On Friday, May 15, 2020, 3:55:32 PM PDT, larsh@apache.org <larsh@apache.org> wrote:






PHOENIX-5808 looks suspicious (I do like the change, it just may introduce this problem)

On Friday, May 15, 2020, 3:48:02 PM PDT, larsh@apache.org <larsh@apache.org> wrote:






This is the exception I'm seeing.

2020-05-15 15:35:36,098 FATAL [RS_OPEN_PRIORITY_REGION-think:16201-1] regionserver.HRegionServer:
ABORTING region server think,16201,1589581955446: The coprocessor org.apache.phoenix.coprocessor.UngroupedAggregateRegionObserver
threw java.lang.NoClassDefFoundError: org/apache/phoenix/compat/hbase/CompatRpcControllerFactory

And indeed CompatRpcControllerFactory is missing from phoenix-server.jar.

Is anybody else seeing this or am I missing something?

-- Lars

Mime
View raw message