phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (Jira)" <j...@apache.org>
Subject [jira] [Updated] (PHOENIX-5561) Map.getOrDefault usage in ConnectionQueryServiceImpl requires JDK 8
Date Tue, 26 Nov 2019 00:54:00 GMT

     [ https://issues.apache.org/jira/browse/PHOENIX-5561?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lars Hofhansl updated PHOENIX-5561:
-----------------------------------
    Affects Version/s:     (was: 4.15.1)
                       4.15.0

> Map.getOrDefault usage in ConnectionQueryServiceImpl requires JDK 8
> -------------------------------------------------------------------
>
>                 Key: PHOENIX-5561
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-5561
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.15.0, 4.14.4
>            Reporter: Geoffrey Jacoby
>            Assignee: Gokcen Iskender
>            Priority: Blocker
>             Fix For: 4.15.0, 5.1.0, 4.14.4
>
>         Attachments: PHOENIX-5561.4.x.001.patch, PHOENIX-5561.master.001.patch
>
>          Time Spent: 50m
>  Remaining Estimate: 0h
>
> PHOENIX-5553 introduced a usage of Map.getOrDefault(), which requires JDK 8. It was checked
into the 4.x branch, even though the 4.x branch should still allow usage by JDK 7 (since HBase
1.x supports JDK 7). 
> If we want to change that assumption, it should be agreed on by the community.
> See CQSI line 926
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message