phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PHOENIX-4823) Issue with Maven Dependencies
Date Thu, 26 Jul 2018 09:57:00 GMT

     [ https://issues.apache.org/jira/browse/PHOENIX-4823?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antoine updated PHOENIX-4823:
-----------------------------
    Description: 
There is a runtime error using phoenix 5.0.0-HBase-2.0 with java and maven. The exception
is when the following method is called: 

DriverManager.getConnection("jdbc:phoenix:localhost");

 

The problem is from hadoop-auth which is included twice in 2 different versions in the dependency
tree. The fix is to do the following:

 

<dependencies>
 <dependency>
 <groupId>org.apache.phoenix</groupId>
 <artifactId>phoenix-core</artifactId>
 <version>5.0.0-HBase-2.0</version>
 <exclusions>
 <exclusion>
 <groupId>org.apache.hadoop</groupId>
 <artifactId>hadoop-auth</artifactId>
 </exclusion>
 </exclusions>
 </dependency>

<dependency>
 <groupId>org.apache.hadoop</groupId>
 <artifactId>hadoop-auth</artifactId>
 <version>3.0.0</version>
 </dependency>
 </dependencies>

  was:
There is a runtime error using phoenix 5.0.0-HBase-2.0 with java and maven. The exception
is when the following method is called: 

DriverManager.getConnection("jdbc:phoenix:localhost");

 

The problem is from hadoop-auth which is included twice in 2 different versions in the dependency
tree. The fix is to do the followingL

 

<dependencies>
 <dependency>
 <groupId>org.apache.phoenix</groupId>
 <artifactId>phoenix-core</artifactId>
 <version>5.0.0-HBase-2.0</version>
 <exclusions>
 <exclusion>
 <groupId>org.apache.hadoop</groupId>
 <artifactId>hadoop-auth</artifactId>
 </exclusion>
 </exclusions>
 </dependency>

 <dependency>
 <groupId>org.apache.hadoop</groupId>
 <artifactId>hadoop-auth</artifactId>
 <version>3.0.0</version>
 </dependency>
</dependencies>


> Issue with Maven Dependencies
> -----------------------------
>
>                 Key: PHOENIX-4823
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4823
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 5.0.0
>            Reporter: Antoine
>            Priority: Major
>             Fix For: 5.0.0
>
>
> There is a runtime error using phoenix 5.0.0-HBase-2.0 with java and maven. The exception
is when the following method is called: 
> DriverManager.getConnection("jdbc:phoenix:localhost");
>  
> The problem is from hadoop-auth which is included twice in 2 different versions in the
dependency tree. The fix is to do the following:
>  
> <dependencies>
>  <dependency>
>  <groupId>org.apache.phoenix</groupId>
>  <artifactId>phoenix-core</artifactId>
>  <version>5.0.0-HBase-2.0</version>
>  <exclusions>
>  <exclusion>
>  <groupId>org.apache.hadoop</groupId>
>  <artifactId>hadoop-auth</artifactId>
>  </exclusion>
>  </exclusions>
>  </dependency>
> <dependency>
>  <groupId>org.apache.hadoop</groupId>
>  <artifactId>hadoop-auth</artifactId>
>  <version>3.0.0</version>
>  </dependency>
>  </dependencies>



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message