phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joshelser <...@git.apache.org>
Subject [GitHub] phoenix issue #307: PHOENIX-4688 Kerberize python phoenixdb
Date Thu, 12 Jul 2018 21:23:24 GMT
Github user joshelser commented on the issue:

    https://github.com/apache/phoenix/pull/307
  
    Ugh, I'm getting frustrated:
    
    I have MIT kerberos on my Mac, so I unblocked myself first by just forcing the minikdc
config file to be made instead of the if-branch you added, Lev.
    
    The next thing, I get a failure trying to launch python from the virtualenv: 
    ```
    /Users/jelser/projects/phoenix.git/phoenix-queryserver/./src/it/bin/test_phoenixdb.sh:
line 59: 66933 Illegal instruction: 4  python $PYTHON_SCRIPT $PQS_PORT
    ```
    
    This was reproducible doing it by hand, so I thought maybe it was related to me using
python-2.7.14 (old).
    
    So, I switched over to Python-3.6.4, reinstalled everything, and I got this.
    ```
    Traceback (most recent call last):
      File "/private/var/folders/4q/q02ykc2j5l1fg8nbs_sczskh0000gp/T/tmp.iUMwkyIZ/lib/python3.6/site-packages/requests_kerberos/kerberos_.py",
line 2, in <module>
        import kerberos
    ImportError: dlopen(/private/var/folders/4q/q02ykc2j5l1fg8nbs_sczskh0000gp/T/tmp.iUMwkyIZ/lib/python3.6/site-packages/kerberos.cpython-36m-darwin.so,
2): Symbol not found: _mempcpy
      Referenced from: /private/var/folders/4q/q02ykc2j5l1fg8nbs_sczskh0000gp/T/tmp.iUMwkyIZ/lib/python3.6/site-packages/kerberos.cpython-36m-darwin.so
      Expected in: flat namespace
     in /private/var/folders/4q/q02ykc2j5l1fg8nbs_sczskh0000gp/T/tmp.iUMwkyIZ/lib/python3.6/site-packages/kerberos.cpython-36m-darwin.so
    ```
    
    I ran into another GH issue saying that pykerberos==1.1.14 fixed it for them, but I'm
not seeing a difference locally.
    
    How do you feel about requiring Docker, @pu239ppy? ;)


---

Mime
View raw message