phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Taylor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4487) Missing SYSTEM.MUTEX table upgrading from 4.7 to 4.13
Date Sat, 23 Dec 2017 02:04:01 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4487?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16302168#comment-16302168
] 

James Taylor commented on PHOENIX-4487:
---------------------------------------

bq. However as discussed offline with [~twdsilva@gmail.com], we decided that since we _officially_
support only 2 client backward versions, this should be fine.
Please don't remove upgrade code without raising a discussion thread on the dev list. Vendor
distros often need upgrade code to remain longer than two minor releases back due to the infrequency
of their upgrade. For example, CDH will go from 4.7 to 4.11. The HDP distro may be even further
behind.
bq. The first line checks if SYSTEM.MUTEX table exists or not. This can be in 2 cases, either
the table doesn't exist at all ot its being migrated to SYSTEM namespace. There is no clear
way of differentiating them and hence there arises a plausible race condition here.
How is it better to go from an unlikely, possible race condition to always throwing an exception
and blocking the upgrade when the mutex table doesn't exist? Please file a separate issue
for handling the race condition properly. This patch improves things at least.
bq. I don't see the need for checking if namespace mapping is enabled or not. 
That check is because if namespaces are enabled, the earlier branch in the upgrade code path
is executed and ensures that the mutex table is created. I'll add a comment.
bq. Also, how do we test this? Any UT or directly tried with a cluster?
Upgrade code needs to be manually checked. I'm hoping [~f.pompermaier] can help test this
once this patch is committed.


> Missing SYSTEM.MUTEX table upgrading from 4.7 to 4.13
> -----------------------------------------------------
>
>                 Key: PHOENIX-4487
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4487
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.14.0, 4.13.1, 4.13.2-cdh5.11.2
>            Reporter: Flavio Pompermaier
>            Assignee: James Taylor
>         Attachments: PHOENIX-4487.patch
>
>
> Upgrading from the official Cloudera Parcel equipped with Phoenix 4.7  to the last unofficial
parcel (4.13 on CDH 5.11.2) I had the same error of https://issues.apache.org/jira/browse/PHOENIX-4293
(apart from the fact that the from version was 4.7...).
> The creation of system.mutex table fixed the problem.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message