phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Poon (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PHOENIX-4382) Upsert of some big values not correct for immutable tables
Date Tue, 19 Dec 2017 17:23:01 GMT

     [ https://issues.apache.org/jira/browse/PHOENIX-4382?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vincent Poon updated PHOENIX-4382:
----------------------------------
    Attachment: PHOENIX-4382.v2.master.patch

[~tdsilva] Can you review v2 patch?

I now added a new IMMUTABLE_SERIALIZATION_V2, which is the default.  It no longer serializes
nulls in the data.

There are now only two values which will return incorrect results in V1.

I tried making columnQualifier negative to distinguish between new and old clients, but it
can't be negative.  So I made the encodingScheme negative.  Can you see if that's ok?  The
tests seem to pass.

Thanks!

> Upsert of some big values not correct for immutable tables
> ----------------------------------------------------------
>
>                 Key: PHOENIX-4382
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4382
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.14.0
>            Reporter: Vincent Poon
>            Assignee: Vincent Poon
>         Attachments: PHOENIX-4382.v1.master.patch, PHOENIX-4382.v2.master.patch, UpsertBigValuesIT.java
>
>
> For immutable tables, upsert of some values like Short.MAX_VALUE results in a null value
in query resultsets.  Mutable tables are not affected.  I tried with BigInt and got the same
problem.
> For Short, the breaking point seems to be 32512.  Numbers smaller than that are fine
(until you get closer to Short.MIN_VALUE...)
> See attached test - testShort() , testBigInt()



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message