phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4317) Update RPC controller to use the updated APIs
Date Tue, 07 Nov 2017 21:22:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4317?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16242903#comment-16242903
] 

Josh Elser commented on PHOENIX-4317:
-------------------------------------

bq. In order to test the changes with setPriority method either we need to move to 1.4 or
wait till Phoenix compiles with HBase 2.0. so IMO, let's made the necessary API changes so
that Phoenix compile with HBase 2.0 and take up the improvement task in follow-on Jira

Let's get the 5.x-HBase-2.0 branch compiling as a priority.

If we need a separate change for the other active Phoenix branches (currently 1.3, 0.98),
let's file a separate issue to get those updated. No need to block using the setPriority(..)
method in our HBase 2.0 branch on updating the HBase 1.x versions being tracked.

> Update RPC controller to use the updated APIs
> ---------------------------------------------
>
>                 Key: PHOENIX-4317
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4317
>             Project: Phoenix
>          Issue Type: Sub-task
>            Reporter: Ankit Singhal
>            Assignee: Ankit Singhal
>              Labels: HBase-2.0
>             Fix For: 4.14.0
>
>         Attachments: PHOENIX-4317.patch
>
>
> PayloadCarryingRpcController to  HBaseRpcController
> DelegatingPayloadCarryingRpcController to DelegatingHBaseRpcController
> Update BalancedQueueRpcExecutor constructor 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message