phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Soldatov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4321) Replace deprecated HBaseAdmin with Admin
Date Wed, 25 Oct 2017 19:29:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4321?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16219358#comment-16219358
] 

Sergey Soldatov commented on PHOENIX-4321:
------------------------------------------

One more note. Admin is using TableName class instead of byte[] for table names. Does it worth
to do refactoring for all our interfaces such as ConnectionQueryServices to use TableName
(actually we have our own TableName class, so in addition we may want to rename it as well)
or we can localize the changes by using TableName.fromBytes() in admin calls? Personally I
would prefer to see usage of TableName everywhere even if it requires more work to get it
done. WDYT [~jamestaylor] [~elserj] 

> Replace deprecated HBaseAdmin with Admin
> ----------------------------------------
>
>                 Key: PHOENIX-4321
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4321
>             Project: Phoenix
>          Issue Type: Sub-task
>            Reporter: Sergey Soldatov
>            Assignee: Sergey Soldatov
>              Labels: HBase-2.0
>             Fix For: 4.13.0
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message