phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Soldatov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4281) Unable to connect apache Phoenix-4.10.0 to Hbase-1.1.1
Date Wed, 11 Oct 2017 17:42:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4281?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16200654#comment-16200654
] 

Sergey Soldatov commented on PHOENIX-4281:
------------------------------------------

user@phoenix.apache.org mailing list is the right place to ask such kind of questions. More
information can be found at https://phoenix.apache.org/mailing_list.html
Please write there and provide more information about your case. Such as full stack trace,
whether namespace mapping is used, etc. You also may turn TRACE logging  and compare the execution
of those two versions of the clients. That may give you a clue why you experience the problem.

> Unable to connect apache Phoenix-4.10.0 to Hbase-1.1.1
> ------------------------------------------------------
>
>                 Key: PHOENIX-4281
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4281
>             Project: Phoenix
>          Issue Type: Test
>    Affects Versions: 4.10.0, 4.11.0
>         Environment: MapR hadoop cluster with hbase-1.1.1 and Phoenix-4.8.1 having 1
hbase master and 3 hbase region servers.
> O.S-6.5 RHEL x64bit 
> CPU-24core each node
> Memory128GB each node
>            Reporter: Pratap
>            Priority: Minor
>             Fix For: 4.8.1
>
>
> Hi Team,
>              I am trying to upgradePhoenix-4.8.1 to 4.10 on my 4 nodes MapR Hadoop cluster
having hbase version1.1.1 with 1 hbase master and 3 hbase region. 
> I have added below jars from phoenix-4.10.0 to hbase-1.1.1 lib  and restarted hbase services
on cluster.( before adding new jars I have moved old phoenix jar and renamed it as jar.bkp
on same location)
> phoenix-4.10.0-HBase-1.1-server.jar
> phoenix-core-4.10.0-HBase-1.1.jar
> Issue:- After upgrading phoenixfrom 4.8.1 to latest version version 4.10.0  I am unable
to connect hbase from  sqlline with below error msg.
> Error: org.apache.hadoop.hbase.snapshot.SnapshotCreationException: org.apache.hadoop.hbase.snapshot.SnapshotCreationException:
Table 'SYSTEM.CATALOG' doesn't exist, can't take snapshot.
>         at org.apache.hadoop.hbase.master.snapshot.SnapshotManager.takeSnapshot(SnapshotManager.java:562)
>         at org.apache.hadoop.hbase.master.MasterRpcServices.snapshot(MasterRpcServices.java:1247)
>         at org.apache.hadoop.hbase.protobuf.generated.MasterProtos$MasterService$2.callBlockingMethod(MasterProtos.java:48522)
>         at org.apache.hadoop.hbase.ipc.RpcServer.call(RpcServer.java:2114)
>         at org.apache.hadoop.hbase.ipc.CallRunner.run(CallRunner.java:101)
>         at org.apache.hadoop.hbase.ipc.RpcExecutor.consumerLoop(RpcExecutor.java:130)
>         at org.apache.hadoop.hbase.ipc.RpcExecutor$1.run(RpcExecutor.java:107)
>         at java.lang.Thread.run(Thread.java:745) (state=,code=0)
>  But I am still able to connect to hbase-1.1.1 from phoenix-4.8.1
> I also tried with phoenix-4.11.0 but getting same error.
> Can you guys please help me to connect hbase-1.1.1 from apache phoenix-4.10 or 4.11.
> Regards
> PratapKumar



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message