phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Taylor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4261) Remove unused netty-all-4.0 dependency
Date Fri, 29 Sep 2017 23:55:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4261?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16186710#comment-16186710
] 

James Taylor commented on PHOENIX-4261:
---------------------------------------

+1

> Remove unused netty-all-4.0 dependency
> --------------------------------------
>
>                 Key: PHOENIX-4261
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4261
>             Project: Phoenix
>          Issue Type: Task
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>             Fix For: 4.12.0
>
>         Attachments: PHOENIX-4261.001.patch
>
>
> See HBASE-18891 for context on why we want to remove it.
> Best as I can tell, we have the netty-all-4.0.x dependency listed, but don't use it (nor
do we even bundle it in the tarball!).
> We should just remove it to remove all doubt about security concerns.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message