phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4191) Not all ITs being run
Date Mon, 11 Sep 2017 15:40:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16161455#comment-16161455
] 

Josh Elser commented on PHOENIX-4191:
-------------------------------------

bq. I know I've run into this problem before, but I forget the solution

Ahh, a guy went and wrote a maven-plugin to do this http://code.revelc.net/warbucks-maven-plugin/index.html

Let me see if I can switch over to that approach as its probably the better long-term solution.

> Not all ITs being run
> ---------------------
>
>                 Key: PHOENIX-4191
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4191
>             Project: Phoenix
>          Issue Type: Bug
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Blocker
>             Fix For: 4.12.0
>
>         Attachments: PHOENIX-4191.001.patch
>
>
> Noticed that not all of the ITs are getting run, specifically SystemTablePermissionsIT.
> It seems like we have the build set up to require that all ITs fall into a specific bucket
of categories. Those not in one of those categories are ignored.
> Marked as blocker as we've had regressions around security in this part of the code before.
Must make sure this test is running before a release happens.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message