phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karan Mehta (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-3757) System mutex table not being created in SYSTEM namespace when namespace mapping is enabled
Date Sat, 23 Sep 2017 08:08:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-3757?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16177621#comment-16177621
] 

Karan Mehta commented on PHOENIX-3757:
--------------------------------------

[~elserj] Any plans to finish this up? I am working on PHOENIX-672 and this patch will help
me run the tests without any PrivilegeException errors. Even if we try to use SYSTEM.MUTEX
directly, if namespace mapping is enabled then the name is automatically transformed to SYSTEM:MUTEX
and it results in TABLE_NOT_FOUND_EXCEPTION. 
[~twdsilva@gmail.com] Any thoughts?

> System mutex table not being created in SYSTEM namespace when namespace mapping is enabled
> ------------------------------------------------------------------------------------------
>
>                 Key: PHOENIX-3757
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-3757
>             Project: Phoenix
>          Issue Type: Bug
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Critical
>              Labels: namespaces
>             Fix For: 4.12.0
>
>         Attachments: PHOENIX-3757.001.patch, PHOENIX-3757.002.patch
>
>
> Noticed this issue while writing a test for PHOENIX-3756:
> The SYSTEM.MUTEX table is always created in the default namespace, even when {{phoenix.schema.isNamespaceMappingEnabled=true}}.
At a glance, it looks like the logic for the other system tables isn't applied to the mutex
table.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message