phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ethan Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-4080) The error message for version mismatch is not accurate.
Date Wed, 16 Aug 2017 21:55:00 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-4080?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16129493#comment-16129493
] 

Ethan Wang commented on PHOENIX-4080:
-------------------------------------

I wonder this is the one. I will give it a try and confirm

ConnectionQueryServiceImpl

{code:java}
            // This is the case if the "phoenix.jar" is not on the classpath of HBase on the
region server
            throw new SQLExceptionInfo.Builder(SQLExceptionCode.INCOMPATIBLE_CLIENT_SERVER_JAR).setRootCause(t)
            .setMessage("Ensure that " + QueryConstants.DEFAULT_COPROCESS_PATH + " is put
on the classpath of HBase in every region server: " + t.getMessage())
            .build().buildException();
{code}


> The error message for version mismatch is not accurate.
> -------------------------------------------------------
>
>                 Key: PHOENIX-4080
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4080
>             Project: Phoenix
>          Issue Type: Wish
>    Affects Versions: 4.11.0
>            Reporter: Ethan Wang
>
> When accessing a 4.10 running cluster with 4.11 client, it referred as 
> The following servers require an updated phoenix.jar to be put in the classpath of HBase:
region=SYSTEM.CATALOG
> It should be phoenix-[version]-server.jar rather than phoenix.jar



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message