phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Purtell <apurt...@apache.org>
Subject Re: Integration Tests hang/fail
Date Mon, 15 May 2017 18:55:53 GMT
Some IT tests have timed out for me in the past. I think that was with 4.9
though. One thing that helps diagnose such issues is running the tests
serially -  'mvn clean install package -DnumForkedIT=1 -DnumForkedUT=1' -
so that when you get a hang it is clear which unit is hanging and there are
not complications like potential interference from a concurrently running
IT or UT. If you do this and do find a hang, that is JIRA worthy.




On Mon, May 15, 2017 at 4:20 AM, Lars George <lars.george@gmail.com> wrote:

> Hi,
>
> I am trying to build a 4.8.2 package and when running the ITs, it
> starts to stall and eventually stops to proceed - without any further
> feedback - when it gets to the "NeedTheirOwnClusterTests" group.
>
> I also get JVM SEGVs at times, and other interesting errors, though in
> the end the stalls are causing the ITs not to progress much further (I
> waited days at times).
>
> And this happens on both my MacPro with 48GB of memory (and Oracle
> JDK), as well as on a beefy Linux VM in the cloud (with OpenJDK),
> which leads me to believe that I am doing something wrong more
> fundamentally? I did a
>
> $ mvn package
>
> followed by a
>
> $ mvn install
>
> or
>
> $ mvn verify
>
> What is going on? Are there any tricks I am missing?
>
> BTW, https://phoenix.apache.org/building.html still talks about
> `-Dhadoop.profile=2.0` which was removed quite a while ago. Should
> that be removed?
>
> Cheers,
> Lars
>



-- 
Best regards,

   - Andy

If you are given a choice, you believe you have acted freely. - Raymond
Teller (via Peter Watts)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message