phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Samarth Jain (JIRA)" <j...@apache.org>
Subject [jira] [Created] (PHOENIX-3697) Tests failing on master and 4.x-HBase-1.1 HBASE-17587
Date Mon, 27 Feb 2017 21:36:45 GMT
Samarth Jain created PHOENIX-3697:
-------------------------------------

             Summary: Tests failing on master and 4.x-HBase-1.1 HBASE-17587
                 Key: PHOENIX-3697
                 URL: https://issues.apache.org/jira/browse/PHOENIX-3697
             Project: Phoenix
          Issue Type: Bug
            Reporter: Samarth Jain


The fix for HBASE-17587 has been checked in. But while HBase 1.1.9 is out, HBase 1.2.5 isn't.
However, in my attempts to change the hbase version in 1.1, I am encountering these build
errors:

[WARNING] The POM for org.apache.hbase:hbase-testing-util:jar:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-it:jar:tests:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-annotations:jar:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-common:jar:1.1.9 is missing, no dependency information
available
[WARNING] The POM for org.apache.hbase:hbase-common:jar:tests:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-protocol:jar:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-client:jar:1.1.9 is missing, no dependency information
available
[WARNING] The POM for org.apache.hbase:hbase-server:jar:1.1.9 is missing, no dependency information
available
[WARNING] The POM for org.apache.hbase:hbase-server:jar:tests:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-hadoop-compat:jar:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-hadoop-compat:jar:tests:1.1.9 is missing, no
dependency information available
[WARNING] The POM for org.apache.hbase:hbase-hadoop2-compat:jar:1.1.9 is missing, no dependency
information available
[WARNING] The POM for org.apache.hbase:hbase-hadoop2-compat:jar:tests:1.1.9 is missing, no
dependency information available

Failed to execute goal on project phoenix-core: Could not resolve dependencies for project
org.apache.phoenix:phoenix-core:jar:4.10.0-HBase-1.1-SNAPSHOT: The following artifacts could
not be resolved: org.apache.hbase:hbase-testing-util:jar:1.1.9, org.apache.hbase:hbase-it:jar:tests:1.1.9,
org.apache.hbase:hbase-annotations:jar:1.1.9, org.apache.hbase:hbase-common:jar:1.1.9, org.apache.hbase:hbase-common:jar:tests:1.1.9,
org.apache.hbase:hbase-protocol:jar:1.1.9, org.apache.hbase:hbase-client:jar:1.1.9, org.apache.hbase:hbase-server:jar:1.1.9,
org.apache.hbase:hbase-server:jar:tests:1.1.9, org.apache.hbase:hbase-hadoop-compat:jar:1.1.9,
org.apache.hbase:hbase-hadoop-compat:jar:tests:1.1.9, org.apache.hbase:hbase-hadoop2-compat:jar:1.1.9,
org.apache.hbase:hbase-hadoop2-compat:jar:tests:1.1.9: Failure to find org.apache.hbase:hbase-testing-util:jar:1.1.9
in https://repository.apache.org/content/repositories/releases/ was cached in the local repository,
resolution will not be reattempted until the update interval of apache release has elapsed
or updates are forced -> [Help 1]


So unfortunately, we would need to downgrade HBase versions in 1.1 and master branches to
a version older than when the bug was introduced by HBASE-16604



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message