phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mujtaba Chohan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-3424) Back compatibility failure: 4.8 -> 4.9 upgrade
Date Fri, 28 Oct 2016 21:16:58 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-3424?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15616614#comment-15616614
] 

Mujtaba Chohan commented on PHOENIX-3424:
-----------------------------------------

To clarify, 4.8.0 was upgraded to current 4.9.0-SNAPSHOT. This exception happened after upgrade
was complete and both client and server were on 4.9.0-SNAPSHOT.

> Back compatibility failure: 4.8 -> 4.9 upgrade
> ----------------------------------------------
>
>                 Key: PHOENIX-3424
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-3424
>             Project: Phoenix
>          Issue Type: Bug
>            Reporter: Mujtaba Chohan
>            Assignee: James Taylor
>
> {noformat}
> Caused by: java.lang.IllegalStateException: Didn't find all required key values in 'COLUMN_FAMILY'
column metadata row
> 	at org.apache.phoenix.coprocessor.MetaDataEndpointImpl.addColumnToTable(MetaDataEndpointImpl.java:671)
> 	at org.apache.phoenix.coprocessor.MetaDataEndpointImpl.getTable(MetaDataEndpointImpl.java:958)
> 	at org.apache.phoenix.coprocessor.MetaDataEndpointImpl.buildTable(MetaDataEndpointImpl.java:543)
> 	at org.apache.phoenix.coprocessor.MetaDataEndpointImpl.loadTable(MetaDataEndpointImpl.java:1210)
> 	at org.apache.phoenix.coprocessor.MetaDataEndpointImpl.createTable(MetaDataEndpointImpl.java:1389)
> 	... 10 more (state=08000,code=101)
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message