phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ravi Kishore Valeti (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-3114) PhoenixMRJobSubmitter fails to create async secondary indexes after PHOENIX-2966
Date Wed, 03 Aug 2016 09:28:20 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-3114?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15405618#comment-15405618
] 

Ravi Kishore Valeti commented on PHOENIX-3114:
----------------------------------------------

[~jamestaylor]

Background on my post.

You mentioned in one comment
"I see. So async index build wasn't working at all, as we would have gotten an exception since
INDEX_TYPE wasn't in the result set"

[~singamteja] replied with
"Yeah. After refactoring was done, executed all the unit tests, when passed assumed that the
async index build worked. However after the RC is out, tried to test on local env's and on
dev clusters which is when found that the functionality is broken."

Just wanted to correct the statement, I wrote this.

"Correction: Async index build was working. Loknath Priyatham Teja Singamsetty while moving
the query to QueryConstants.java, missed INDEX_TYPE. https://github.com/apache/phoenix/commit/04df7bca07607f9db7f7bba5f726bff6013b81e0
and hence the builds started failing."


No complaints on the patch.

> PhoenixMRJobSubmitter fails to create async secondary indexes after PHOENIX-2966
> --------------------------------------------------------------------------------
>
>                 Key: PHOENIX-3114
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-3114
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.8.0
>            Reporter: Loknath Priyatham Teja Singamsetty 
>            Assignee: Loknath Priyatham Teja Singamsetty 
>             Fix For: 4.8.0
>
>         Attachments: phoenix-3114.patch
>
>
> After the refactoring done as part of PHOENIX-2966, The INDEX_TYPE column is missing
in the ASYNC_SECONDARY_INDEX query to fetch the async index rows from system.catalog table.
This is being used inside PhoenixMRJobSubmitter. Unfortunately, the existing async secondary
index test cases for phoenix-mr-automation are succeeding. Created separate JIRA for writing
e2e test for secondary indexes
> 2016-07-25 07:36:10,744 DEBUG [8ff-shared--pool2-t1] security.HBaseSaslRpcClient - Will
read input token of size 32 for processing by initSASLContext
> 2016-07-25 07:36:10,745 DEBUG [8ff-shared--pool2-t1] security.HBaseSaslRpcClient - Will
send token of size 32 from initSASLContext.
> 2016-07-25 07:36:10,745 DEBUG [8ff-shared--pool2-t1] security.HBaseSaslRpcClient - SASL
client context established. Negotiated QoP: auth
> Exception in thread "main" org.apache.phoenix.schema.ColumnNotFoundException: ERROR 504
(42703): Undefined column. columnName=INDEX_TYPE
> 	at org.apache.phoenix.compile.RowProjector.getColumnIndex(RowProjector.java:159)
> 	at org.apache.phoenix.jdbc.PhoenixResultSet.findColumn(PhoenixResultSet.java:178)
> 	at org.apache.phoenix.jdbc.PhoenixResultSet.getByte(PhoenixResultSet.java:334)
> 	at org.apache.phoenix.mapreduce.index.automation.PhoenixMRJobSubmitter.getCandidateJobs(PhoenixMRJobSubmitter.java:151)
> 	at org.apache.phoenix.mapreduce.index.automation.PhoenixMRJobSubmitter.scheduleIndexBuilds(PhoenixMRJobSubmitter.java:179)
> 	at org.apache.phoenix.mapreduce.index.automation.PhoenixMRJobSubmitter.main(PhoenixMRJobSubmitter.java:272)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message