phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Please share the status of GSoC project
Date Thu, 02 Jun 2016 16:43:13 GMT
A NoNode error is not a failure condition. HBase regularly makes 
decisions on whether or not nodes actually exist in HBase...

Josh Elser wrote:
> Please keep all conversations on the mailing list.
>
> Pranavan Theivendiram wrote:
>> Hi Josh. I had hadoop-2.5.1 jars. I replaced the old jars with new
>> hadoop 2.6.4 jars. (Earlier I got some class not found errors. I fixed
>> it by replacing 2.5.1 with 2.6.4)
>>
>> I am thinking like, this is a problem between hbase and zookeeper.
>> *
>> *
>> *2016-06-02 14:52:00,080 [myid:] - INFO [ProcessThread(sid:0
>> cport:2181)::PrepRequestProcessor@651] - Got user-level KeeperException
>> when processing sessionid:0x155106b3fcb0000 type:delete cxid:0x1f
>> zxid:0x13 txntype:-1 reqpath:n/a Error
>> Path:/hbase/rs/localhost,60000,1464859314301 Error:KeeperErrorCode =
>> NoNode for /hbase/rs/localhost,60000,1464859314301*
>>
>> Above is an INFO log that I have found in zookeeper.
>>
>>
>> Thanks
>>
>> *T. Pranavan*
>> /*Junior Consultant *| Department of Computer Science & Engineering
>> ,University of Moratuwa/
>> *Mobile| *0775136836
>>
>> On 2 June 2016 at 22:04, Josh Elser <josh.elser@gmail.com
>> <mailto:josh.elser@gmail.com>> wrote:
>>
>> Did you download tarballs from Apache? Some vendor?
>>
>> If you downloaded the Apache HBase 1.2.1 binary tarball, you will
>> have hadoop-2.5.1 jars on the HBase classpath. It would be good to
>> make sure you have consistent versions of Hadoop/HDFS on the HBase
>> classpath.
>>
>> Pranavan Theivendiram wrote:
>>
>> Please find the answers inline.
>>
>> On 2 June 2016 at 21:22, Josh Elser <josh.elser@gmail.com
>> <mailto:josh.elser@gmail.com>
>> <mailto:josh.elser@gmail.com <mailto:josh.elser@gmail.com>>> wrote:
>>
>> How did you install HDFS and HBase and what versions of
>> each did you
>> use? It looks like you might somehow have incompatible
>> libraries.
>>
>> Hadoop - 2.6.4
>> Zookeeper - 3.4.8
>> Hbase - 1.2.1
>>
>>
>> I also haven't seen any message from you on the hbase lists
>> (user or
>> dev). Make sure you subscribe to the user@ list before posting.
>>
>> I sent a mail to hbase dev list.
>>
>> Can you able to map what are the incompatible libraries from the
>> logs
>> that I have shared?
>>
>>

Mime
View raw message