phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajeshbabu Chintaguntla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PHOENIX-1880) Connections from QueryUtil.getConnection don't work on secure clusters
Date Thu, 30 Apr 2015 20:31:07 GMT

    [ https://issues.apache.org/jira/browse/PHOENIX-1880?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14522200#comment-14522200
] 

Rajeshbabu Chintaguntla commented on PHOENIX-1880:
--------------------------------------------------

+1 for 4.4

> Connections from QueryUtil.getConnection don't work on secure clusters
> ----------------------------------------------------------------------
>
>                 Key: PHOENIX-1880
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-1880
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.3.0, 4.4.0
>            Reporter: Geoffrey Jacoby
>              Labels: patch
>             Fix For: 4.4.0
>
>         Attachments: PHOENIX-1880.patch
>
>
> QueryUtil.getConnection(Configuration) and QueryUtil.getConnection(Properties, Configuration)
both only take the zookeeper quorum from the Configuration, and drop any other properties
on the config object. In order to connect to secure HBase clusters, more properties are needed.
This is a similar problem to PHOENIX-1078, and the likely fix is similar: copy the configuration
parameters into the Properties object before using it. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message