phoenix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Phoenix | 4.x-HBase-0.98 #1436
Date Mon, 06 Feb 2017 16:55:44 GMT
See <https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/1436/changes>

Changes:

[ankitsinghal59] PHOENIX-3652 Users who do not have global access to hbase cluster can't

------------------------------------------
Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on H17 (ubuntu) in workspace <https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/>
Cloning the remote Git repository
Cloning repository https://git-wip-us.apache.org/repos/asf/phoenix.git
 > git init <https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/> # timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/phoenix.git
 > git --version # timeout=10
 > git -c core.askpass=true fetch --tags --progress https://git-wip-us.apache.org/repos/asf/phoenix.git
+refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/phoenix.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/phoenix.git # timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/phoenix.git
 > git -c core.askpass=true fetch --tags --progress https://git-wip-us.apache.org/repos/asf/phoenix.git
+refs/heads/*:refs/remotes/origin/*
 > git rev-parse origin/4.x-HBase-0.98^{commit} # timeout=10
Checking out Revision 52867eb570862e4091a7911157e23e985910b6ec (origin/4.x-HBase-0.98)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 52867eb570862e4091a7911157e23e985910b6ec
 > git rev-list c702b263d789e99c1aa1d734e4e38bacdf9fa2c4 # timeout=10
No emails were triggered.
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
MAVEN_OPTS=-Xmx3G

[EnvInject] - Variables injected successfully.
[Phoenix-4.x-HBase-0.98] $ /bin/bash -xe /tmp/hudson1635046252133522159.sh
+ echo 'DELETING ~/.m2/repository/org/apache/htrace. See https://issues.apache.org/jira/browse/PHOENIX-1802'
DELETING ~/.m2/repository/org/apache/htrace. See https://issues.apache.org/jira/browse/PHOENIX-1802
+ echo 'CURRENT CONTENT:'
CURRENT CONTENT:
+ ls /home/jenkins/.m2/repository/org/apache/htrace
htrace
htrace-core
[Phoenix-4.x-HBase-0.98] $ /home/jenkins/tools/maven/latest3/bin/mvn -U clean install -Dcheckstyle.skip=true
[INFO] Scanning for projects...
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] 'dependencies.dependency.version' for org.apache.kafka:kafka_2.11:jar must be a valid
version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version], <https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,>
line 307, column 13
[ERROR] 'dependencies.dependency.version' for org.apache.kafka:kafka-clients:jar must be a
valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
312, column 13
[ERROR] 'dependencies.dependency.version' for org.apache.kafka:kafka_2.11:jar:test must be
a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
317, column 13
[ERROR] 'dependencies.dependency.version' for org.apache.kafka:kafka-clients:jar:test must
be a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
324, column 13
[ERROR] 'dependencies.dependency.version' for org.apache.kafka:kafka-tools:jar must be a valid
version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version], <https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,>
line 331, column 13
 @ 
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]   
[ERROR]   The project org.apache.phoenix:phoenix-kafka:4.10.0-HBase-1.2-SNAPSHOT (<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml)>
has 5 errors
[ERROR]     'dependencies.dependency.version' for org.apache.kafka:kafka_2.11:jar must be
a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
307, column 13
[ERROR]     'dependencies.dependency.version' for org.apache.kafka:kafka-clients:jar must
be a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
312, column 13
[ERROR]     'dependencies.dependency.version' for org.apache.kafka:kafka_2.11:jar:test must
be a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
317, column 13
[ERROR]     'dependencies.dependency.version' for org.apache.kafka:kafka-clients:jar:test
must be a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
324, column 13
[ERROR]     'dependencies.dependency.version' for org.apache.kafka:kafka-tools:jar must be
a valid version but is '${kafka.version}'. @ org.apache.phoenix:phoenix-kafka:[unknown-version],
<https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/ws/phoenix-kafka/pom.xml,> line
331, column 13
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
Build step 'Invoke top-level Maven targets' marked build as failure
Archiving artifacts
Compressed 99.93 KB of artifacts by 64.0% relative to #1433
Recording test results
ERROR: Step ?Publish JUnit test result report? failed: No test report files were found. Configuration
error?


Mime
View raw message