perl-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Peters <>
Subject Re: [patch]
Date Sat, 17 Apr 2010 21:56:18 GMT
On 04/17/2010 05:27 PM, Philip M. Gollucci wrote:

>> What are people's thoughts on that?  TAP::Harness is included in 5.12,
>> but not 5.10.  Test::Harness is bundled with earlier versions of perl.
>>   We use Test::Harness extensively in Apache::Test, so this would be
>> switching part of Apache::Test but not all of it.

Newer versions of Test::Harness are just wrappers around TAP::Harness. 
So if you're using a modern Test::Harness you already have a dependency 
on TAP::Harness, which is actually just a module included in the 
Test::Harness distribution. And TAP::Harness works with at least 5.6.x 
and probably earlier.

Are there actually people who will upgrade mod_perl but not the Perl 
module dependencies?

Michael Peters
Plus Three, LP

View raw message